Dynamischer Kalender mit Google Tabellen

Dynamischer Kalender mit Google Tabellen

Hier zeige ich Euch wie ein dynamischer Kalender in Google Tabellen / Spreadsheets erstellt werden kann. Der Aufbau dauert zwar vielleicht etwas länger als die Quick & Dirty – Lösung aber im Nachhinein muss nur noch die Jahreszahl geändert werden und der Kalender passt sich sofort entsprechend an.



Im unteren Bereich habe ich die Formeln zum kopieren bereitgestellt. Ihr könnt die Datei mit dem Google Kalender natürlich auch gerne herunter laden. Ich habe einmal die Datei als XLSX und einmal als PDF-Format unten zum Download bereitgestellt.

Ich benutze im Kalender auch die bedingte Formatierung. Wer sich mit der bedingten Formatierung noch gar nicht auskennt sollte sich vielleicht auch erst einmal dieses Tutorial anschauen:
Bedingte Formatierung ganz einfach (Google Tabellen / Spreadsheets). Das Tutorial zeigt wie eine bedingte Formatierung für die entsprechenden Zellen angewendet werden kann.

Du arbeitest das erste mal mit Google Tabellen oder überhaupt mit einem Tabellenkalkulationsprogramm? Dann solltest Du Dir vielleicht erst einmal dieses Tutorial anschauen:
Einfache Berechnungen für Anfänger (Google Tabellen)
Das Tutorial zeigt ganz einfache Berechnungen und sollte den Einstieg wesentlich leichter machen.

Die benutzten Formeln für den dynamischen Kalender:

Zelle B4:
=DATUM(A1;1;1)

Zelle D4:
=EDATUM(B4;1)

Zelle B5:
=WENN(MONAT(B4+1)=MONAT(B$4);B4+1;"")

Für die bedingte Formatierung wird folgende Formel benötigt:
=UND(WOCHENTAG(A4;2)>5;ISTZAHL(A4))

Die Dateien zum Download:

Euch gefällt die Datei und Ihr wollt Euch unbedingt bedanken?
Hier ist meine AMAZON – Wunschliste [HIER KLICKEN] 😉

Download Kalender als PDF – Dokument

Download Kalender als PDF – Dokument im Zip-Ordner

Download Kalender als XLSX Dokument für Excel im Zip-Ordner

Als ODS konnte ich das Dokument nicht zur Verfügung stellen da die Formeln dafür nicht optimiert sind.

Falls Ihr nicht wisst wie eine Datei in Google Tabellen importiert wird schaut mal hier:
Datei in eine Google Tabelle importieren

Das Video-Tutorial "Dynamischer Kalender":

 



Ähnliche Beiträge

4 Kommentare

  1. Ruberg sagt:

    Hallo
    Es ist intressant ein Kalender Erstellen wo Urlaub,Feiren,Feiertagen und Urlaub enthalten ist.

  2. Marco sagt:

    Servus und vielen Dank für dieses sehr gute Video!!

    Ich würde gerne deinen Kalender noch erweitern… (aber bekomme es alleine nicht auf die Reihe :D)
    Undzwar:

    Ich würde gerne über bedingte Formatierung diejenigen Datenzellen rot färben, die in einem anderen Tabellenblatt in einer Zeil erwähnt werden. (Tage für die ich einen Eintrag gemacht habe).

    Ist das irgendwie mittels eigener Formel möglich?

    • Chris sagt:

      Schau Dir mal dieses Tutorial dazu an:
      Feiertage farbig markieren (Google Tabellen / Spreadsheets)
      In der anderen Tabelle kannst Du die Datumseinträge mit Namen benennen ("Benannte Bereiche").
      In der bedingten Formatierung kannst Du dann über den SVerweis und INDIREKT darauf zugreifen. Das sieht dann in etwa so aus:
      =SVERWEIS(A1;INDIREKT("DeinBenannterName");1;0)
      Wenn Du mehrere bedingte Formatierungen hast musst Du noch anhand der Reihenfolge in der Eintragsliste die Priorität anpassen.
      Viele Grüße
      Chris

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.