Dynamischer Kalender (OpenOffice Calc)

Dynamischer Kalender (OpenOffice Calc)

Hier zeige ich Euch wie ein dynamischer Kalender in OpenOffice Calc erstellt werden kann. Damit habt Ihr die Möglichkeit nur die Jahreszahl zu ändern und der Kalender passt sich automatisch an. Die Wochenenden erhalten durch die bedingte Formatierung einen farbigen Hintergrund.



Im unteren Bereich findet Ihr die Formeln falls Ihr die Tabelle selbst erstellen wollt oder einen Link für die gesamte Datei. Im Video wird Euch dann Schritt für Schritt gezeigt wie die Tabelle erstellt werden kann. Zusätzlich zeige ich Euch in dem Video wie Ihr die Seite für den Ausdruck auf Querformat einstellen könnt und die Tabelle auf die Seite eingepasst werden kann. Das Format des Kalenders oder Jahresplans könnt Ihr natürlich Euren Wünschen entsprechend anpassen.

Wer das erste mal mit OpenOffice Calc oder überhaupt mit einem Tabellenkalkulationsprogramm arbeitet sollte sich vielleicht auch erst einmal dieses Tutorial anschauen:
EINFACHE BERECHNUNGEN / Grundlagen für Anfänger (OpenOffice Calc)
Das Tutorial zeigt ganz einfache Berechnungen und sollte den Einstieg wesentlich leichter machen.

Dieses Tutorial ist extra für Anfänger die sich mit dem Tabellenkalkulationsprogramm OpenOffice Calc noch nicht so viel beschäftigt haben. Es zeigt die Funktionen und Möglichkeiten Schritt für Schritt.

Die verwendeten Formeln:

Zelle B4:
=DATUM(A1;1;1)

Zelle B5:
=WENN(MONAT(B4+1)=MONAT(B$4);B4+1;"")

Zelle D4:
=EDATUM(B4;1)

Bedingte Formatierung:
UND(WOCHENTAG(X34;2)>5;ISTZAHL(X34))
INFO: X34 ist die Zelle die bei der Auswahl aller Zellen diesen Rahmen hat. Sollte es bei Euch eine andere Zelle sein die einen Rahmen hat müsst Ihr diese Zelle statt X34 eintragen.

Den dynamischen Kalender zum Download:

Wer keine Zeit hat, den Kalender in OpenOffice Calc nachzubasteln kann sich natürlich auch gerne die Datei hier herunter laden.

Download Der Kalender im normalen ODS Format

 

Download  Der Kalender im ODS Format als ZIP Datei

 

Euch gefällt die Datei und Ihr wollt Euch unbedingt bedanken?
Hier ist meine AMAZON – Wunschliste [HIER KLICKEN] 😉

 

Das Video-Tutorial für den dynamischen Kalender:

 



Das könnte Dich auch interessieren

16 Kommentare

  1. Wissenbach sagt:

    Sehr gut erklärt., so kann man als Sportverein Termine schön eintragen.
    Gut wäre ein dazu passendes Lernvideo mit dem Thema wie lassen sich Formulare über eine Cloud von mehreren Personen bearbeiten.
    Danke sagt die Bogenabteilung des TFC.

    • Chris sagt:

      Vielen Dank für das positive Feedback 😉
      Das mit dem bearbeiten eines Formulars von mehreren Personen habe ich auf die TODO-Liste geschrieben. Vielen Dank für den Tipp.

      Viele Grüße
      Chris

  2. Axel sagt:

    Funktioniert super und problemlos.
    Ein dickes Daumen hoch 👍.

  3. adventure_3 sagt:

    Super gemacht , hat mir sehr gut geholfen Kalender zu bauen.

  4. Petra Schlehhuber sagt:

    Vielen Damk für die gute Einweisung, hat richtig Spaß gemacht!

  5. Patrick sagt:

    Super Anleitung
    Ich habe noch eine Frage:
    Wenn ich in den leeren Feldern am Ende vom Monat die Tage vom nächsten Monat erscheinen lassen möchte (evtl hellgrau), wie wäre dann die Formel?

    • Chris sagt:

      Du musst einmal die WENN Funktion abändern und die bedingte Formatierung anpassen.
      Die WENN Funktion dient dazu nur den aktuellen Monat anzuzeigen. Also kannst Du diese komplett weg lassen und trägst nur den zweiten Parameter der Funktion ein (also dass was zurückgegeben wird wenn die Funktion Wahr ist)
      Anschließend musst Du nur noch die bedingte Formatierung mit einer WENN Funktion ausstatten. Die Formel entspricht etwa der Formel die in der Zelle steht. Als Formatierung nimmst Du dann graue Schrift.
      Wenn es nicht funktioniert, dann schreib mal die Formel hier rein die Du bisher versucht hast anzuwenden.
      Viele Grüße
      Chris

  6. krueuw sagt:

    Für die aktuelle LibreOffice Version gibt die Formel nur ein leeres Feld z.B. für den 32. und danach je eine Fehlermeldung ab 33. Das ist an sich auch logisch, wenn man bedenkt, dass das Feld für den 32. ja leer ist und im Feld für den 33. darauf Bezug genommen wird. Folgende Lösung:

    =WENN(ISTFEHLER(WENN(MONAT(B4+1)=MONAT(B$4);B4+1;""));"";WENN(MONAT(B4+1)=MONAT(B$4);B4+1;""))

  7. Chris sagt:

    Hallo,

    deine Tutorials sind top! Heißen also zurecht so 😉

    Habe nun folgenden Fall: In einem Auftragsbuch sind die geplanten Termine für die Durchführung der Projektarbeiten eingetragen. Ist es möglich, dass ich in Tabelle "Auftragsbuch" die Termine eintrage und diese dann automatisch in Tabelle "Kalender" farbig hinterlegt werden? Oder umgekehrt, dass ich im Kalender Termine vergebe, die dann automatisch ins Auftragsbuch eingetragen werden?

    Geht bestimmt. Aber bislang habe ich hierzu noch nicht den richtigen Ansatz gefunden.

  8. Max sagt:

    Hallo,
    ich hoffe du kannst mir weiterhelfen.
    Ich habe Bilder/Grafiken in verschiedene Zellen eingefügt und in der Zellle verankert.
    Wenn ich das Dokument speicher und dann wieder öffne – fehlen die Bilder/Grafiken!
    Wie kann ich die Bilder/Grafiken einbetten oder mit dem Dokument verknüpfen?

    • Chris sagt:

      Das ist natürlich nicht so leicht zu beantworten wo der Fehler liegen könnte. Was ich erst einmal prüfen würde ist ob die Datei das richtige Format hat (zum Beispiel ODF Format).
      Wenn Du die Datei transportierst, verschiebst oder sonstiges kann es eventuell sein dass der Bezug zu der Grafik nicht mehr vorhanden ist.
      Ansonsten noch diese Einstellungen:
      OpenOffice Laden und Speichern
      Mehr fällt mir dazu jetzt auch nicht ein.
      Viele Grüße
      Chris

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.