Daten filtern mit der Funktion FILTER (Google Tabellen)

In diesem Tutorial zeige ich Euch wie Ihr bei den GOOGLE TABELLEN die Funktion FILTER anwenden könnt. Damit könnt Ihr sehr leicht große Datenmengen nach Euren wünschen entsprechend filtern.



Es gibt auch eine kleine Erweiterung und zwar die Kombination aus FILTER und IMPORTRANGE. Das Tutorial dazu könnt Ihr Euch hier anschauen:
Filter und Importrange kombiniert (Google Tabellen)

Wer das erste mal mit Google Tabellen oder überhaupt mit einem Tabellenkalkulationsprogramm arbeitet sollte sich vielleicht auch erst einmal dieses Tutorial anschauen:
Einfache Berechnungen für Anfänger (Google Tabellen)
Das Tutorial zeigt ganz einfache Berechnungen und sollte den Einstieg wesentlich leichter machen.

Dieses Tutorial ist extra für Anfänger die sich mit dem Tabellenkalkulationsprogramm GOOGLE TABELLEN / SPREADSHEETS noch nicht so viel beschäftigt haben und zeigt die Funktionen und Möglichkeiten Schritt für Schritt.

Das Video-Tutorial „Daten filtern mit der Funktion FILTER (Google Tabellen )“

 



Das könnte Dich auch interessieren

8 Kommentare

  1. Alfred Bublik sagt:

    Hallo Chris,
    ich secke beim filtern etwas fest.
    Mir fehlt die Möglichkeit „alles anzeigen“ .
    ich benutz folgenden Code der auch wunderbar klappt:

    =FILTER(allespiele!A2:S;allespiele!A2:A=AN1;allespiele!G2:G=AT1;allespiele!I2:I=AV1;allespiele!J2:J=AW1)

    die Felder AN1, AV1, AW1 sind Zellen wo ein Dropdown menü ist nach dessen Kriterium ich dann Filtere.

    ich brauche aber auch die möglichkeit das er im feld AN1 nicht filtert sondern alles anzeigt.

    kann man das evtl. mit einer wenn formel machen?

    wenn AN1=“Name“ dann alles anzeigen ansonsten Filtern nach AN1 so in der Art.

    oder mittels button und mit ein skript hinterlegt?

    da der board eigene Filter ja löschen beherscht sollte dafür ein Befehl vorhanden sein oder?

    ansonsten hab ich schon sehr viele funktionen anhand deiner videos einbauen können.

    mfg Alfred

    • Chris sagt:

      Hi Alfred,
      versuche mal innerhalb der Filterfunktion in etwa folgendes:

      =filter(A1:C;B1:B=WENN(G1="*";B1:B;G1))

      Du machst in Deinem Dropdown zusätzlich ein Sternchen mit rein also ein *
      In dem Beispiel von mir wäre jetzt in der Zelle G1 das Dropdown und im Bereich B1:B sind die entsprechenden Daten.
      Wird ein Sternchen ausgewählt gibt es als Ergebnis alle Daten. Dann wird direkt B1:B=B1:B dort eingetragen und alles angezeigt.
      Wenn kein Sternchen ausgewählt ist, dann wird als Ergebnis der WENN Funktion genau der ausgewählte Eintrag vom Dropdown übergeben und gefiltert.
      Ich habe das gerade mal kurz getestet und es scheint zu funktionieren 😉
      Das musst Du halt nur für Deine Tabelle etwas anpassen.
      Viele Grüße
      Chris

  2. Alfred Bublik sagt:

    =FILTER(allespiele!A2:S;allespiele!A2:A=WENN(AN1=“*Gilde“;allespiele!A2:A;AN1);allespiele!G2:G=WENN(AT1=“*Kurse“;allespiele!G2:G;AT1);allespiele!I2:I=WENN(AV1=“*in/out“;allespiele!I2:I;AV1);allespiele!J2:J=WENN(AW1=“*Tee“;allespiele!J2:J;AW1);allespiele!K2:K=WENN(AX1=“*Score“;allespiele!K2:K;AX1);allespiele!L2:L=WENN(AY1=“*Punkte“;allespiele!L2:L;AY1);allespiele!R2:R=WENN(BE1=“*Angriffe“;allespiele!R2:R;BE1))

    eingefügt und angepasst. läuft perfekt.
    war mein grundgedankr gar nicht soweit weg.
    könnte man da hetzt in jeden filter noch eine sortierung einbauen? oder würde eine sortierung nur einmal am schluss gehen ?

    kleines dankeschön ist unterwegs.

    LG

    • Chris sagt:

      Ja, das mit der WENN Funktion war schon genau richtig 😉
      Du kannst Deinen Filter noch mit der Funktion SORT umschließen.
      Das heißt Du hast dann in etwa so eine Formel:
      =SORT(ALLE_DEINE_FILTER_BEFEHLE; X; TRUE)
      Wobei das X für eine Zahl steht. Die Zahl ist dann relativ vom Beginn des Bereichs gerechnet welche sortiert werden soll.
      Willst Du also die zweite Spalte von Deinen gefilterten Daten sortieren trägst Du da statt dem X einfach eine 2 ein.
      Ich weiß nicht ob ich das schon angesprochen habe (leider kann ich mir nicht alle Gespräche merken) aber wenn Du sehr viel mit Daten arbeitest, dann schau Dir unbedingt mal die QUERY Funktion an.
      https://toptorials.com/funktion-query-wie-sql-google-tabellen/
      https://toptorials.com/importrange-query-kombiniert-google-tabellen/
      Das ist eine Funktion die sehr umfangreiche Möglichkeiten bietet Daten zu sortieren und zu filtern. Falls Du mal in irgend einer Form mit SQL zu tun hattest dann wäre es ein Kinderspiel für Dich.
      Vielen Dank übrigens 😉 Ist schon angekommen 😉
      Viele Grüße
      Chris

  3. Alfred Bublik sagt:

    ich hab noch nie programmiert. alles neuland. werd mir die passenden videos suchen und die ein oder andere idee rauspicken

  4. Alfred Bublik sagt:

    schön wenn was klappt. anstelle von spaltenindex und true (oder false) hab ich 2 zellen zur sortierung eingegeben.
    diese Zellen werden mittels buttons und miniskript mit spaltenindex und true/false vom benutzer gefüllt.
    perfekt

    • Chris sagt:

      Klingt super. Ich lagere auch meistens Teile einer Formel so aus, dass man die Werte schnell ändern kann. Für andere Benutzer können dann diese ausgelagerten Bereiche auch noch freigegeben werden und die Formel bleibt geschützt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.