SUMMEWENNS ganz einfach (OpenOffice Calc)

In diesem Tutorial zeige ich Euch wie Ihr bei OPEN OFFICE CALC die Funktion SUMMEWENNS (mit einem „S“ am Ende) anwenden könnt. Mit der SUMMEWENNS – Funktion könnt Ihr Zellen anhand mehrerer Kriterien gefiltert summieren. Es gibt auch die Funktion SUMMEWENN (ohne „S“ am Ende). Dies ist die einfache Variante mit nur einem Suchkriterium.



Es gibt übrigens noch weitere WENN Funktionen. Zum einen die ZÄHLENWENN und auch die ZÄHLENWENNS Funktion. Hier ist auf das „s“ am Ende zu achten. Das „s“ am Ende bedeutet das mehrere Kriterien benutzt werden können um die Daten zu filtern. ZÄHLENWENNS zählt die Zellen und SUMMEWENNS summiert die Zellen anhand von mehreren Kriterien.

Natürlich gibt es auch noch die normale WENN Funktion und auch die Möglichkeit diese WENN Funktion zu verschachteln.

Wer das erste mal mit OpenOffice Calc oder überhaupt mit einem Tabellenkalkulationsprogramm arbeitet sollte sich vielleicht auch erst einmal dieses Tutorial anschauen:
EINFACHE BERECHNUNGEN / Grundlagen für Anfänger (OpenOffice Calc)
Das Tutorial zeigt ganz einfache Berechnungen und sollte den Einstieg wesentlich leichter machen.

Dieses Tutorial ist extra für Anfänger die sich mit dem Tabellenkalkulationsprogramm OpenOffice Calc noch nicht so viel beschäftigt haben. Es zeigt die Funktionen und Möglichkeiten Schritt für Schritt.

Das Video-Tutorial „SUMMEWENNS ganz einfach (Open Office Calc)“

 



Das könnte Dich auch interessieren

8 Kommentare

  1. TheoM sagt:

    Hi und danke für Deine vielen tollen Tutorials rund um OpenOffice, LiebreOffice etc…
    Im Moment stecke ich mit summewenns gerade etwas fest.
    Ich versuche Reisekosten von mehreren Reisen in einem Ergebnistabellenblatt am Ende zusammenzufassen.
    Folgendes geht für ein Tabellenblatt =SUMMEWENNS(Trapani.C9:C23;Trapani.B9:B23;“.*PKW.*“) dann zu Fahrten mit PKW 37,2 Euro führt.
    Nun habe ich wie erwähnt jeweils ein Tabellenblatt führ jede Dienstreise in der Datei, sprich Trapani, Zürich, Rom etc und mcöhte über die Tabellenblätter die Zahlen summieren so dass am Ende eine Gesamtsumme für alle Zellen mit PKW gebildet wird.
    Geht dass?

    Danke Theo

    • Chris sagt:

      Hi Theo,
      Du kannst zum Beispiel die Zellen mit den Endsummen in jedem Tabellenblatt benennen. Zum Beispiel in der einen Tabelle benennst Du die Zelle mit der Gesamtsumme von Zürich einfach SummeZuerich und die Gesamtsumme von Rom meinetwegen SummeRom. In dem Tabellenblatt wo Du alles zusammenaddieren möchtest, kannst Du jetzt zum Beispiel =SummeZuerich+SummeRom schreiben.
      Das benennen von Zellen geht ganz einfach. Du wählst einfach die Zelle aus und schreibst dort oben links einfach den Namen in das Eingabefeld. Da siehst Du normalerweise den Eintrag A1 wenn Du die Zelle A1 ausgewählt hast. Hier kannst Du später auch die Zellen über das Auswahlfeld direkt auswählen, weil dort alle benannten Zellen drin stehen.
      Ein Tutorial dafür findest Du übrigens hier:
      https://toptorials.com/mit-namen-rechnen-zellen-benennen-open-office-calc/
      Viele Grüße
      Chris

  2. TheoM sagt:

    Danke Dir Chris,

    sehr nett dass Du geantwortet hast.
    Ist schon eigentlich genial, nur hatte ich mir vorgestellt, dass ich eine Vorlage erstelle und die ganzen Information am Schluss automatisch befüllt werden, so dass ich am Schluss, wenn ich ein neues Tabellenblatt habe nicht im Endsummenblatt immer wieder händisch Summexxx hinzufügen muss.
    Hab gerade auch gemerkt, dass ich ein Feld dass ich in einem Tabellenblatt PKW benannt habe nicht im nächsten ebenfalls so benenn kann, klar ist ja schon vergeben…wäre zu einfach gewesen 😉 zum addieren dann nur auf dem Endsummenblatt PKW einzugeben.
    Kann ich dass automatisieren mit dem $ Zeichen oder geht es wirklich nur von Hand?
    Hoffe ich beschrieben die Sache verständlich.

    Deine Tutorials sind wirklich klasse…danke Theo

    • Chris sagt:

      Hi Theo,
      soweit ich weiß gibt es nur noch die einfachen Varianten die in etwa so aussehen:
      =Tabelle1.A1+Tabelle2.A1+Tabelle3.A1 und so weiter. Wobei die Namen der Tabellenblätter wichtig sind und natürlich kürzer sein könnten. Wenn Du Leerzeichen im Tabellennamen benutzt musst Du das in Hochkommata einschließen.
      Im Grunde genommen hast Du das ja schon so ähnlich gelöst.
      oder:
      =SUMME(Tabelle1.A1:Tabelle5.A1) über mehrere Tabellen hinweg.
      Hier sollten die gewünschten Summen aber alle in der gleichen Zelle der Tabellen stehen.
      Die Vorlage kannst Du ja vorbereiten. Wenn Du das einmal erstellt hast sollte sich da ja auch nichts mehr ändern. Deshalb eigentlich auch die Namen in den Zellen. Da wärst Du meiner Meinung nach flexibler.
      Die gleichen Namen für benannte Zellen darfst Du natürlich nicht verwenden, aber ich denke jedes Tabellenblatt hat ja auch irgendwie eine andere Bedeutung und dadurch könnte diese benannte Zelle einen entsprechenden Präfix oder Suffix (aus dem Tabellenblattnamen) bekommen.
      Viele Grüße
      Chris

      • TheoM sagt:

        Danke noch mal Chris,

        hat soweit funktioniert.
        Ich habe jetz mit summewenns() die Salden aus der jeweiligen Tabelle geholt und in der Tabelle immer mit der gleichen Spalte und Zelle auf dem Auswertungsblatt =Tabelle1.A1+Tabelle2.A1+Tabelle3.A1 anzeigen lassen.
        Einzier Wermutstropfen ist, dass ich den String dann für alle Tabellen und auch neu dazukommende anpassen muss.
        Sprich =Tabelle1.A1+Tabelle2.A1+Tabelle3.A1+Tabelle4.A1+Tabelle5.A1+Tabelle6.A1

        Ist es möglich, dass eine neue Tabelle selbständig eingefüht wird, also wenn ich Tabelle Tabelle7 erstelle, dass diese dann =Tabelle1.A1+Tabelle2.A1+Tabelle3.A1+Tabelle4.A1+Tabelle5.A1+Tabelle6.A1+Tabelle7.A1 ergänzt wird.

        Viele Grüße Theo

        • Chris sagt:

          Schau Dir nochmal die zweite Variante an die ich Dir als letztes geschickt habe.
          Hiermit kannst Du Zwei Tabellenblätter auswählen und alles was an Tabellenblättern dazwischen liegt wird summiert.
          Wenn Du also =SUMME(Tabelle1.A1:Tabelle10.A1) nimmst brauchst Du die Tabellen 2-9 nicht in der Formel einfügen. Du kannst sogar weitere Tabellenblätter dazwischen schieben und diese werden dann berechnet.
          Mit dazwischen liegen ist gemeint, dass diese unten in den Registerblättern entsprechend angeordnet werden müssen. Würdest Du jetzt zum Beispiel die Tabelle „Tabelle2“ vor die „Tabelle1“ setzen, würde „Tabelle2“ nicht mitberechnet werden.
          Bei neuen Tabellen die Du erstellst, kannst Du diese einfach dazwischen schieben und sie werden mitberechnet 😉
          Viele Grüße
          Chris

          • TheoM sagt:

            Super Chris,

            jetzt funktioniert es.
            Hatte mich so in die erste Variante verbissen und den anderen Hinweis nicht richtig verstanden.

            Liebe Grüße Theo…

            PS: Werde demnächst was spenden…

          • Chris sagt:

            Super. Freut mich zu hören dass es geklappt hat 😉

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.