Wörter in zufällige Zelle (Excel)

Wörter in zufällige Zelle (Nur Spalten)

Ich wurde gefragt ob es möglich ist Wörter in einer zufälligen Zelle zu schreiben. Als Beispiel wurde Zelle B1 bis B79 angegeben.
Das ist natürlich kein Problem und es gibt sicherlich mehrere Möglichkeiten Wörter zufällig in eine Zelle zu schreiben. Hier in dem Beispiel werde ich das genau nach der Vorgabe machen.Als erstes brauche ich eine Zelle die mir die Zufallszahl ausgibt. Ich nehme dafür mal die Zelle A1.



Ein etwas ausführlicheres Tutorial für Zufallszahlen habe ich für Euch hier: ZUFALLSZAHLEN und ZUFALLSBEREICH.
Dann benötigen wir noch eine WENN Funktion.
Ein Tutorial über die Wenn Funktion findet Ihr hier: WENN – FUNKTION.
Mit der WENN Funktion können wir dann eine Prüfung vornehmen. Wenn wir jetzt in jeder WENN Funktion einfach nur einen Wert von 1 bis 79 überprüfen, haben wir die Lösung. Ich benutze hierfür einfach eine Funktion mit dem Namen ZEILE(). Hiermit wird mir dann genau die Zeilennummer ausgegeben. Da jede WENN Funktion in einer anderen Zeile steht wird jede entsprechend anders behandelt.

Die benötigten Formeln:

ZELLE A1:
=ZUFALLSBEREICH(1;79)

ZELLE B1: (Formel rein kopieren und von dort aus nach unten kopieren)
=WENN($A$1=ZEILE();"Treffer";"Kein Treffer")

Wörter in zufälliger Zelle (Zeilen und Spalten)

Man könnte das ganze noch weiter führen indem man auch die Spalte zufällig auswählt. Hier könnte man das ganze noch mit einer UND Funktion kombinieren. Man erstellt eine zweite Zufallszahl für die Spalte (meinetwegen A2). In der Prüfung nimmt man dann die UND Funktion und kombiniert diese.

Die benötigten Formeln:

ZELLE A1:
=ZUFALLSBEREICH(1;79)

ZELLE A2:
=ZUFALLSBEREICH(2;6)

ZELLE B1: (Formel rein kopieren und von dort aus nach unten kopieren)
=WENN(UND($A$1=ZEILE();$A$2=SPALTE());"Treffer";"Kein Treffer")

Hier könnt Ihr jetzt die Formel aus Zelle B1 in daneben liegenden und darunter liegenden Zellen kopieren.

Euch gefällt das Tutorial und Ihr möchtet Euch bedanken?
Hier ist meine AMAZON – Wunschliste [HIER KLICKEN] 😉



Das könnte Dich auch interessieren

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.