Arrayformel ganz einfach mit Excel

Arrayformel ganz einfach mit Excel

In diesem Tutorial zeige ich Euch wie Ihr eine Arrayformel ganz einfach mit Excel anwenden könnt.  Ich erkläre die Arrayformeln mit Summe in zwei verschiedenen Varianten und so einfach wie möglich. Bekommt jetzt also keine Panik, denn eigentlich sind die Array Formeln, zumindest was diese Beispiele angeht wirklich easy.



Das Ganze geht natürlich noch wesentlich komplizierter aber ich werde Euch davon vorerst verschonen.
Als kleinen Bonus zeige ich Euch in diesem Video Tutorial aber trotzdem zum Schluss noch eine weitere Möglichkeit zur Berechnung mit der Arrayformel.
In den Beispielen für die Arrayformel in Verbindung mit der Funktion Summe liefert die eine Variante mehrere Ergebnisse (Ergebnisse werden in mehreren Zellen gleichzeitig berechnet) und die andere Variante wird nur in einer Zelle ein Ergebnis zurück liefern.

Wie sollte man sich eine Arrayformel vorstellen

Normalerweise ist so eine Arrayformel nichts anderes als eine Liste von Zellen und Formeln die der Reihe nach abgearbeitet werden. In diesem Beispiel werden diese Bereiche bei der Berechnung einfach nur wie eine Liste Zeile für Zeile abgearbeitet.
Zum besseren Verständnis solltet Ihr Euch das Video anschauen.

Hinweis:

Solche eine Arrayformel wird auch Matrixformel oder CSE Formel genannt.
CSE = Control, Shift Enter (STRG + UMSCHALTTASTE + EINGABETASTE

Tastenkombination für eine Arrayformel:

Um so eine Arrayformel ganz einfach mit Excel anzuwenden benötigt Ihr eine spezielle Tastenkombination. Das einfügen der Formel mit der Eingabetaste alleine recht nicht aus. Ihr müsst dafür die folgende Tastenkombination drücken:

STRG + SHIFT + ENTER

Tastenkombination Arrayformel

Tastenkombination Arrayformel

Übrigens: Es funktioniert nicht die geschweiften Klammern in der Formel selbst einzusetzen, Ihr müsst das über die oben genannten Tastenkombination machen.

Die Verwendeten Formeln:

Angefangen habe ich in dem Tutorial mit der nachfolgenden Formel.
=B2:B6*C2:C6
Nach Eingabe der Formel mit der Tastenkombination STRG + SHIFT und ENTER (STRG + GROSSSCHREIBTASTE + EINGABETASTE) sieht die Formeln dann automatisch so aus:{=B2:B6*C2:C6}
Durch die vom Programm automatisch hinzugefügten geschweiften Klammern sieht man dass es sich um eine Arrayformel handelt.

Beispiel 1 (nachdem die Zellen D2 bis D6 ausgewählt wurden):
Die Eingabe muss mit der Tastenkombination STRG + SHIFT + EINGABE erfolgen.
=B2:B6*C2:C6

Beispiel 2 (kommt in Zelle D7):
Hier reicht die Eingabe der Formel mit der Eingabetaste. Eine Eingabe mit der Tastenkombination ist nicht erforderlich.
=SUMME(D2:D6)

Beispiel 3 (kommt in Zelle F2):
Die Eingabe muss mit der Tastenkombination STRG + SHIFT + EINGABE erfolgen.
=SUMME(B2:B6*C2:C6)

Beispiel 4 (nachdem die Zellen B10 bis E13 ausgewählt wurden:
Die Eingabe muss mit der Tastenkombination STRG + SHIFT + EINGABE erfolgen.
Nur das Ergebnis:
=A10:A13*B9:E9
Das Ergebnis inklusive dem Ausgangswert:
=A10:A13*B9:E9+A10:A13

 

Die Projektdatei: Arrayformel ganz einfach mit Excel

Download

 

Euch gefällt das Tutorial und Ihr möchtet Euch bedanken?
Hier ist meine AMAZON – Wunschliste [HIER KLICKEN] 😉

 

Das Video "Arrayformel ganz einfach mit OpenOffice Calc"

 



Das könnte Dich auch interessieren

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.